2015/10/04

一旦復旧も・・・

・・・結局RRASでNATを有効にしたら、Webの公開は やはりイレギュラーな方法でしか出来なくなった(´ヘ`;)



現状を結論から記すなら、
RRAS、NAT(デマンドダイアルも同時に) は、巷のTipsどおり行う。

違うのは、
Web鯖公開の為に施す [NAT]-[対象となるデマンドダイアル]のプロパティでの、
[サービスとポート]タブ-[サービス]枠内の[Webサーバー (HTTP)]を設定を "行わない。"
コトだろう。 その上で、IIS7.5で設定しているWebサイトの[バインド]で、
種類ホスト名ポートIPアドレス
http80192.168.xxx,zzz
httpwww.sample.com80192.168.xxx.zzz
httpwww.sample.com80*
の ように設定すると、何故かWeb鯖は支障なく公開できた。
現状 この理由は確認出来ていないし、コレが安全な設定であるのかも後日検証する域だ。 しかし NATを有効にし、[Webサーバー (HTTP)]を設定で IISでのサイト公開で用いるIPアドレスを設定してしまうと、 サイトの外部公開が出来なくなるのは事実であり、上述のような方法でしか 今のところ 動作を確認出来ていない。 そして その状態から判断するに、IISの応答処理自体は かなりアバウトに 全IPへのポート80へのリクエストを受けるコトで開始され、 [バインド]で そのポート80へのアクセスが、どのサイトを呼び出しているのかを判断し、対応するサイトを返しているのも間違いがない。 コレが バインドが既定で存在していなかった2003時代なら IIS内に複数設定したサイト毎に 個別にIPを割り当てるコトで ポートやルーティングを小細工して 1サーバで複数サイトを稼動できるようにしたモノだが、そのような設定の手間は IIS7.5以降では 必要ないのかも知れない・・・ さりとてコレも確認した訳ではナイ、現状での動作からは その様にしか判断出来ない と云うだけだ。 さて、この問題に気付いたコト自体は数年前、新おきつね鯖にWindowsServer2008R2を導入した際に遡る。 旧おきつね鯖 WindowsServer2003EE で 出来ていた設定を そのまま施したのだが、
RRAS仕様変更? -Windows Server 2008 R2 - Base by day, bass by night.  [ 20110709 ]
・・・このサイトでも扱われているように、Webサイトが公開出来ない。 巷に溢れるTipsの通り RRASを導入し、NATを使わない 単純なデマンドダイアルのセットアップを行っただけであれば、 2003だろうが2008R2だろうが、全く同じ手順で設定でき 且つ、ISPへの接続を処理出来る。 そもそも RRASの その他機能についても、巷には それぞれ単体のTipsばかり、その全体をカスタム導入するような 凝った説明があるサイトは 残念ながら確認出来なかった・・・ 個別の用途として利用するだけなら、それらの通りに設定するだけで問題なく稼動するのだから ぢつにワナとしか云いようがナイ。 仮に その状態にこぎつけ、[NAT]に 対象となるデマンドダイアルを設定し、[サービスとポート]タブ[サービス]枠内の [Webサーバー (HTTP)]を設定したとたん、IIS7.5で設定完全に済ませあったWebサイトは、外部から閲覧出来なくなってしまうのだ・・・ で これが、先日おきつね鯖を仮復旧させる際には 逆の状態になったワケだ。 NATの設定自体は正しく行っているにもかかわらず NATとしては動作出来ない、そのまま[サービスとポート]タブでの設定を行うと、 何故か Web鯖公開は機能する意味不明な状態・・・ こうなってくると コレはもしかしたら方法が無いコトもナイのだろうと思わせるのだが、 実際は、何度色んな組み合わせを試しても、NATが有効になったアトでは、[サービスとポート]タブでの設定を行うと、 サイト公開できなくなってしまった・・・ コレ自体は 新おきつね鯖へ最初に2008R2を導入したトキと変わらないワケなんだよね(-_-;) 過去 似た問題抱えて困ったヒトは多いと思うし、本当に仕様として不可であるのか、ナニかしらルーティングやIPの割り振り方で 解決出来るのか、このままうやむやでは 中々に後味悪い上、今後のおきつね鯖運用で不安を残すコトになるので、この辺に関しては 明日月曜日に再度検証して結論を導き出したいと考えている。

・・・1Uラックマウントサーバの 2つあるオンボードLANチップのウチ、兼ねてより具合の悪かった1つが ほぼ完全に死亡。 LANハブのランプが、消えては少し経ってまた点く を繰り返していた・・・ HUB自体は正常である。 ルーティング以外の DNS WINS Web NTP を負担させていたLANポート[Servers]を制御していた石だったのだが、 まぁ 息も絶え絶えになりつつも、最後まで処理を続けてくれたみたいだ。 取り敢えず オンボードである為取り外すコトは出来ない、因ってWindowsのデバイスマネージャ上で無効化した・・・ このLANポート[Servers]には、ルーティング以外の主要なサーバ処理を一手に負担させていた。 ・・・とは云え、メインのルーティンなどに比べれば、処理量は遥かに小さなモノではある。 しかし 壊れかけの石には 相当に大きな負担だった事だろう・・・ 真に おつかれさま といった感。 で、これが壊れて使えないとなると 割り当てていたIPの振り方も一考を要する。 最初は簡易に復旧させる程度にしか考えてなった事もあり、 手抜きで全IPを、機器自身を表すだけの為に利用していたポート[SV00]へ振ったのだが、 これだと以前の Web公開出来ない状況に後戻りしてしまった・・・ どうも、DNSと機器固有情報を扱うIPが1つのポートに混在してしまうと、 既知の方法では どれを用いても何かしら衝突してしまって機能しない・・・ そこで、 おきつねネットワークのデフォルトゲートウェイのみを担当させていたポート[RRAS]へ DNSを、 Web WINS NTP を [SV00] に それぞれ割り当てた上で 少し試行錯誤、設定を新たに整え直す事で、 今度は漸く 本来あるべき設定で、再度 Webサーバとして稼動出来る状態には出来た。 引用としては変だが 怪我の功名 と云った趣き。 で、ココまでで触れてなかった未解決の問題が1つ、肝心のNATとしては機能してなかったりするw コレ起因で LAN内ルーティングが全く機能しないので、その辺の設定を確認しないとならないのだが、 ぶっちゃけ この報告するのが限界だな 眠くて・・・、残りは起きてからの作業にしよう。 って、それが終わらないと、おきつね1st/2nd機はネットワークへ接続出来ないんだケドなぁ・・・(; -_-) ・・・このログ? 急遽おきつね鯖からアゲました、報告までに(^_^;)

2 件のコメント:

  1. ”真に おきつねさま”です。

    一旦復活して(スカイプポップアップしたので)すぐ落ちたのでどうしたのかと思ったらLANチップがおなくなりですか・・・
    まぁ作業さえすれば復活できそうなのがなりより・・・

    ( ゚д゚)ハッ! どこからおきつねさまはログを上げている・・・?まさか脳内から直接(ry

    おお~きなむーねのおきつねさまーの♪
    壊れかけのLAN石~♪
    あ~るよ~る・・・

    \突然の死/

    返信削除
    返信
    1. いつのまに・・・(;^ω^)

      削除